articelbaner

مقالات و
مستندات آموزشی

نحوه فعالسازی SSH در تجهیزات سیسکو

این مورد را ارزیابی کنید
(2 votes)

در این مقاله با نحوه فعالسازی SSH در سوییچ‌ها و روترهای CISCO آشنا خواهید شد.

                                

                                    دریافت فایل
                                

 

SSH یا Secure Shell اساساً روشی ایمن برای دسترسی و ارسال فرمان‌ها به CLI) Command Line Interface) دستگاه مقصد از طریق ارتباط شبکه‌ای و بدون اتصال کابل کنسول به طور مستقیم می‌باشد. بر خلاف استاندارد Telnet که داده را به فرمت متن ساده ارسال می‌کند، SSH از رمزنگاری استفاده می‌کند که از محرمانه بودن و یکپارچگی داده اطمینان حاصل خواهد کرد. دو نسخه از SSH وجود دارد که SSH v2 نسخه بهبود یافته SSH v1 (به دلیل وجود حفره‌های امنیتی مشاهده شده در SSH v1) می‌باشد. به صورت پیش فرض اگر SSH در دستگاه‌های سیسکو فعال شود، هر دو نسخه را شامل خواهد شد.

 

فعالسازی SSH در سوییچ و روتر با سیستم عامل سیسکو (Cisco SSH)

می‌توان این فرآیند را به چهار گام ساده زیر تقسیم کرد:

 آماده‌سازی دستگاه (اعمال تنظیمات نام دستگاه، نام دامین، نام کاربری و رمزهای عبور)

 آماده‌سازی شبکه (آدرس‌دهی IP و مسیریابی)

 تولید کلید RSA و فعالسازی SSH

 اعمال SSH بر روی خطوط vty

در ادامه جزئیات پیکربندی هر مرحله اشاره شده در بالا شرح داده خواهد شد. توجه داشته باشید جهت پیکربندی اولیه دستگاه به منظور دسترسی به تنظیمات آن نیاز به استفاده از کابل کنسول و اتصال به طور مستقیم می‌باشد.

 

1. آماده‌سازی دستگاه

در مرحله آماده‌سازی، می‌بایست به دستگاه، نام و نام دامنه اختصاص دهید. در این مثال ما از دیتابیس Local برای احراز هویت استفاده خواهیم کرد، بنابراین لازم است که حتما حداقل یک نام کاربری و رمز عبور برای روتر تعریف گردد. در غیر اینصورت SSH بدون آن اعمال نخواهد شد. دستور وارد شده در مثال زیر چگونگی انجام این کار را نمایش داده است:

 

Router(config)#hostname GeekRtr
 GeekRtr(config)#ip domain-name mustbegeek.com
 GeekRtr(config)#username admin password letmein123
 GeekRtr(config)#username admin privilege 15
 GeekRtr(config)#username monitor password letmesee123
 GeekRtr(config)#enable password letmeconfig123

 

در این مثال ما دو نام کاربری (‘admin’ و ‘monitor’) با دو سطح دسترسی متفاوت ایجاد کرده‌ایم. این مورد بعداً در بخش تصدیق هویت توضیح داده خواهد شد.

 

2. آماده‌سازی شبکه

پیکربندی شبکه ممکن است بسته به توپولوزی شبکه‌ای که شما با آن کار می‌کنید متفاوت باشد. در این مثال، از یک توپولوژی ساده‌ که اینترفیسی از یک روتر را به یک سوییچ استاندارد با یک PC متصل به آن وصل کرده است، استفاده خواهیم کرد. به PC یک IP استاتیک و آدرس IP اینترفیس Fa 0/1 روتر به عنوان gateway به آن اختصاص داده شده است. همچنین یک آدرس IP Management به اینترفیس Loopback روتر تخصیص داده شده است. به دیاگرام و پیکربندی زیر توجه نمایید:

 

Diagram

 

فرض کنید تمامی کابل‌ها به طور صحیح متصل شده‌اند، حال اقدام به اختصاص آدرس IP به اینترفیس Fa0/1 و اینترفیس Loopback روتر با پیکربندی زیر می‌کنیم:

 

GeekRtr(config)#interface fa0/1
GeekRtr(config-if)#ip address 192.168.0.1 255.255.255.0
GeekRtr(config-if)#no shutdown
GeekRtr(config-if)#exit
GeekRtr(config)#interface loopback0
GeekRtr(config-if)#ip address 1.1.1.1 255.255.255.255
GeekRtr(config-if)#no shutdown
GeekRtr(config-if)#exit

 

در این مثال، نیازی به پیکربندی Routing نمی‌باشد و مشکلی با دسترسی به آدرس IP وجود نخواهد داشت. اما بهتر است همیشه تمامی موارد بررسی گردند، در این مورد می‌بایست ارتباط Ping به PC از اینترفیس Loopback روتر بررسی گردد.

 

GeekRtr#ping 192.168.0.2 source loopback0
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.0.2, timeout is 2 seconds:
Packet sent with a source address of 1.1.1.1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/4 ms

 

بر اساس خروجی فوق ارتباط Ping از اینترفیس Loopback روتر به PC برقرار است و ارتباط برعکس آن هم همچنبن به طور صحیح عمل خواهد کرد. بنابراین، می‌توانیم نتیجه بگیریم که پیکربندی شبکه تماماً درست انجام شده است و می‌توانیم تمرکز اصلی را در ادامه مقاله بر پیکربندی SSH معطوف نماییم.

 

Bina Network Monitoring Software

 

3. تولید کلید RSA و فعالسازی SSH

حال اقدام به تولید کلید RSA می‌کنیم که توسط SSH و به منظور رمزنگاری داده‌های آن استفاده خواهد شد. در این مرحله نیاز است تا اندازه و طول کلید مشخص گردد. هرچه طول کلید بیشتر باشد، رمزنگاری آن قدرتمندتر خواهد بود. اما زمان بیشتری برای تولید کلید نیاز می‌باشد. در مثال زیر، ما از طول کلید 1024 استفاده کرده‌ایم و این در حالی است که اندازه پیش فرض آن 512 می‌باشد.

 

GeekRtr(config)#crypto key generate rsa
The name for the keys will be: GeekRtr.mustbegeek.com
Choose the size of the key modulus in the range of 360 to 2048 for your
 General Purpose Keys. Choosing a key modulus greater than 512 may take
 a few minutes.
How many bits in the modulus [512]: 1024
% Generating 1024 bit RSA keys, keys will be non-exportable...[OK]

 

پس از پیکربندی فوق، پیغامی مشابه پیغام زیر مشاهده خواهید کرد:

 

*Mar 1 00:01:21.727: %SSH-5-ENABLED: SSH 1.99 has been enabled

این پیغام نشان می‌دهد که SSH بر روی روتر فعال شده است. برای اطمینان، می‌توان با استفاده از دستور Show ip ssh در روتر خروجی تنظیمات را بررسی نمود:

 

GeekRtr#show ip ssh
SSH Enabled - version 1.99
Authentication timeout: 120 secs; Authentication retries: 3

 

ممکن است تعجب کنید که چرا در خروجی فوق به جای نسخه 1 یا نسخه 2، نسخه 1.99 نمایش داده شده است. این به دلیل این است که به صورت پیش فرض Cisco SSH از دو نسخه SSH v1 و SSH v2 پشتیبانی می‌کند. عدد 1.99 این سازگاری را نمایش می‌دهد. اگرچه، طبق اظهارات تیم امنیتی، به شدت توصیه می‌شود SSH v1 غیرفعال گردد. برای انجام آن، می‌توان با دستور ساده زیر SSH v1 را غیرفعال نمود:

 

GeekRtr(config)#ip ssh version 2

 

پس از آن، اجازه دهید مجدد تنظیمات را بررسی نماییم:

 

GeekRtr#show ip ssh
 SSH Enabled - version 2.0
 Authentication timeout: 120 secs; Authentication retries: 3

 

بسیار خوب، همانطور که در خروجی فوق مشاهده می‌کنید، version 2.0 نمایش داده شده است (حال احساس امنیت بیشتری می‌کنیم) و این بدین معنی است که تنظیمات این مرحله انجام گرفته است. حال سراغ مرحله نهایی می‌رویم.

 

4. اعمال SSH بر روی خطوط vty

در مرحله قبل فعالسازی SSH انجام شد. حال تنها دو مورد باقی مانده است: اعمال SSH بر روی خط vty) Virtual Terminal Line) و سپس تنظیم روش احراز هویت برای استفاده از نام کاربری Localی که در مرحله آماده‌سازی دستگاه ایجاد کرده‌ایم. با استفاده از دستور زیر می‌توان این تنظیمات را انجام داد:

 

GeekRtr(config)#line vty 0 4
 GeekRtr(config-line)#transport input ssh
 GeekRtr(config-line)#login local

 

دستور Line vty 0 4 برای مشخص کردن حداکثر تعداد Sessionهای ترمینال مجازی مجاز روی روتر استفاده می‌شود. در این مثال، ما حداکثر 5 Session (از Session شماره 0 تا Session شماره 4) را در این روتر مجاز کرده‌ایم. دستور transport input ssh ،SSH را بر روی خط vty فعال می‌کند و همچنین سایر روش‌ها را مثل Telnet غیرفعال می‌کند. بنابراین این بدین معنی است که پس از اعمال این دستور، SSH تنها روشی است که شما می‌توانید برای دسترسی به روتر استفاده نمایید. دستور login Local به منظور احراز هویت هر تلاش ورود به سیستم در مقابل نام کاربری local مورد استفاده قرار می‌گیرد و به خاطر داشته باشید که ما پیش‌تر دو نام کاربری local ایجاد کردیم (به مرحله اول رجوع کنید). با این پیکربندی ما موفق به فعالسازی SSH بر روی روتر سیسکو شدیم.

 

5. تصدیق هویت

حال از طریق PC اقدام به تست و بررسی دسترسی به روتر موردنظر با استفاده از SSH می‌کنیم. در این مثال ما از نرم‌افزار Putty استفاده می‌کنیم.  آدرس Loopback 1.1.1.1 را به عنوان مقصد و SSH را نوع اتصال انتخاب می‌کنیم.

 

Putty

 

سپس اقدام به لاگین می‌کنیم. بنابراین همانطور که قبلاً پیکربندی کردیم (به مرحله اول رجوع کنید)، نام کاربری را ‘admin’ و رمز عبور را ‘letmein123’ وارد می‌کنیم.

خواندن 1373 دفعه

ثبت نام وبینار آنلاین

شما میتوانید در وبینار آنلاین شرکت کنید، همین حالا ثبت نام کنید


ثبت نام وبینار آنلاین

ثبت نام سمینار

سمینار بزرگ یک روز با مدیریت سرویس.


همین حالا صندلی خود را رزرو کنید!

تمامی حقوق این سایت برای شرکت داناپرداز محفوظ است. | Copyright © 2018 Dana Pardaz Co 

 

 

لطفاً جهت دانلود فایل، ایمیل خود را وارد نمایید:

ادامه... ×